Skip to main content

qTranslate y WordPress

Si usas el plugin qTranslate en un WordPress más nuevo que la versión 3.8.1, lo más probable es que al editar páginas ( o cualquier contenido traducible ) aparezca un error en el backend con el siguiente texto:

The qTranslate Editor has disabled itself because it hasn't been tested with your WordPress version yet. This is done to prevent WordPress from malfunctioning. You can reenable it by clicking here (may cause data loss! Use at own risk!). To remove this message permanently, please update qTranslate to the corresponding version.

El caso es que qTranslate, ha dejado de desarrollarse, por lo que hay dos opciones.

  1. Utilizar mqTranslate, un fork basado en el propio qTranslate y totalmente compatible (más info aquí)
  2. Arreglar qTranslate.

Si tu opción es arreglar qTranslate, debes saber que es bastante sencillo, y que funcionará correctamente – comprobado – hasta con la vesión 4.1 de wordpress (la versión más nueva hasta el día de escribir estas líneas).

Lo único que debes hacer es i) dirigirte al directorio siguiente de tu instalación de wordpress:

/wp-content/plugins/qtranslate

ii) Hacer una copia de seguridad del fichero qtranslate.php

iii) Localizar la línea en que aparece define(‘QT_SUPPORTED_WP_VERSION’, ‘3.8.1’) y sustituir el valor de la constante por tu versión de WordPress. En el caso de la versión 4.1, deberás escribir lo siguiente:

define('QT_SUPPORTED_WP_VERSION', '4.1');

Con esto debería quedar solucionado, aunque con el tiempo es más que probable que haya que migrar definitivamente a mqTranslate.

Suerte!

Una respuesta a “qTranslate y WordPress”

  1. Yo he ido tirando del cambio que comentas desde hace varias actualizaciones de WP pero al final siempre termina dando problemas con el editor. Finalmente terminé pasando a mqtranslate y por el momento no tengo queja.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *